Checkout temporarily unavailable

Incident Report for Squarespace

Resolved

The maintenance is complete and checkout is now available. Thankyou for your patience.
Posted Apr 16, 2026 - 01:23 EDT

Monitoring

Checkout temporarily unavailable: we are upgrading our systems to serve you better. Checkout might be temporarily unavailable from April 16 1:00 AM ET to 2:00 AM ET.
Posted Apr 16, 2026 - 00:59 EDT
This incident affected: Accounts & Billing.