-Log in verification emails are being delayed -Email Campaigns are being delayed -System related emails are being delayed
Posted Jan 24, 2026 - 14:17 EST
Update
This is affecting the deliverability of all emails being delayed.
We are still monitoring the situation.
Posted Jan 24, 2026 - 14:01 EST
Identified
The issue has been identified and is external to Squarespace. We are actively monitoring the situation and will provide updates as more information becomes available.
**Email Campaigns are also experiencing a delay in deliverability.
Posted Jan 24, 2026 - 13:27 EST
Update
We are continuing to investigate this issue.
Posted Jan 24, 2026 - 13:13 EST
Update
We are continuing to investigate this issue.
Posted Jan 24, 2026 - 12:53 EST
Update
We are continuing to investigate the issue.
Posted Jan 24, 2026 - 12:37 EST
Investigating
We're investigating issues with login verification emails and password reset emails being delayed.
Posted Jan 24, 2026 - 12:10 EST
This incident affected: Email Campaigns and Accounts & Billing.